PHP 7.1 安装 ssh2 扩展


作者: 我不是鱼 (2017-03-06 08:56) 分类: PHP   标签: ssh2 PHP 7.1

最近的项目要将文件从一台服务器上传到另外一台。本想着搭建ftp服务器,但为了节省时间,没有去做,而直接想着使用 sftp 或 scp 上传。这里就要用到 ssh2 扩展,下面说下如何在 PHP 7.1 下安装 ssh2,因为安装过程不算很顺利。

首先要安装 libssh2 开发库,否则安装扩展的时候会出现这个错误:

checking for gawk... gawk
checking for ssh2 support... yes, shared
checking for ssh2 files in default path... not found
configure: error: The required libssh2 library was not found.  You can obtain that package from http://sourceforge.net/projects/libssh2/
ERROR: `/tmp/pear/temp/ssh2/configure --with-php-config=/usr/local/php7/bin/php-config --with-ssh2' failed

在 Centos 下用 yum 安装:

[root@lnmp lnmp.cn]# yum install libssh2 libssh2-devel

安装完成后再安装ssh2 扩展,这个扩展并不包含在 PHP 7.1 的源码中,需要另行下载安装。而这样安装方法首选始终都是 pecl:

[root@lnmp lnmp.cn]# pecl install ssh2

安装失败:

pecl/ssh2 requires PHP (version >= 4.0.0, version <= 6.0.0), installed version is 7.1.0
No valid packages found
install failed

原因已经提示得很明显。不支持 PHP 7。PHP 7 已经发行一年多,但有些扩展库的更新还是没有跟上。于是乎到它主页上看个究竟:

https://pecl.php.net/package/ssh2

原来在 16 年中的时候有更新过版本,并且描述中说到 1.0 版本已经支持 PHP 7

ssh2 1.0 and above is PHP 7 only. To install a version that is PHP 5 compatible you can run 'pecl install ssh2-0.13'

那么刚才安装失败应该就是没选中合适版本的缘故,那么为何会这样呢,描述中其实也有提到原因:

Note that reaching version 1.0 does NOT indicate we've reached a stable release.

是因为 1.0 版本还不是稳定版,所以 pecl 默认安装 0.13 稳定版。那这个问题只需要指定版本就可以解决:

[root@lnmp lnmp.cn]# pecl install ssh2-1.0

终于安装成功:

Build process completed successfully
Installing '/usr/local/php7/lib/php/extensions/no-debug-non-zts-20160303/ssh2.so'
install ok: channel://pecl.php.net/ssh2-1.0
Extension ssh2 enabled in php.ini

并且提示 ssh2 已经加入到 php.ini 中。

但如果从未用 pecl 设置好 php_ini 指明 php.ini  的位置,那就会出现类似下面这样的提示,就得有时候可能要自己手动加进 php.ini

Build process completed successfully
Installing '/usr/local/php7/lib/php/extensions/no-debug-non-zts-20160303/ssh2.so'
install ok: channel://pecl.php.net/ssh2-1.0
configuration option "php_ini" is not set to php.ini location
You should add "extension=ssh2.so" to php.ini

可以用如下命令设置 php_ini

[root@lnmp lnmp.cn]# pecl config-set php_ini /usr/local/php7/lib/php.ini

确认 ssh2.so 在 php.ini 中之后,记得 reload php-fpm:

[root@lnmp lnmp.cn]# systemctl reload php-fpm

php ssh2

关于 ssh2 函数:
http://php.net/manual/en/book.ssh2.php

上传或下载文件:
http://php.net/manual/en/function.ssh2-scp-send.php
http://php.net/manual/en/function.ssh2-scp-recv.php

前一篇: 安装 PHP 5.3 时出现 configure: error: Cannot find libmysqlclient under /usr.
后一篇: pecl_http configure: error: please install and enable pecl/raphf


添加评论

昵称:


验证码